package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)`)
var str = `-h
-help
-v
-version
--help
--version
-mail:moo
--mailer:mm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}