using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href\s*=\s*(([\""\']).*?)\2.*?>.*?<\/a>";
string input = @"<a style = ""display: block;"" href = ""website.com"">something here</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}