$re = '/<a.*?href\s*=\s*(([\"\']).*?)\2.*?>.*?<\/a>/m';
$str = '<a style = "display: block;" href = "website.com">something here</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);