using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"K";
string input = @"KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}