package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)K`)
var str = `KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}