$re = '/K/m';
$str = 'KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);