const regex = /s\p{L}\p{L}innosti|s\p{L}\p{L}innos\p{L}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s\\p{L}\\p{L}innosti|s\\p{L}\\p{L}innos\\p{L}', 'gmi')
const str = `EXEKUČNÝ PRÍKAZ NA VYKONANIE EXEKÚCIE ZRÁŽKAMI ZO MZDY
PRÍKAZ NA ZAČATIE EXEKÚCIE ZRÁŽKAMI ZO MZDY A INÝCH PRÍJMOV
Žiadosť o poskytnutie súčinnosti pri vykonávaní exekúcie:
Výzva zamestnávateľovi – žiadosť o poskytnutie súčinnosti
zastavenie exekúcie
ZRUŠENIE EXEKUČNÉHO PRÍKAZU
Vec: ZRUŠENIE EXEKUČNÉHO PRÍKAZU - naša značka: EX 11299/08 vrátane všetkých
Vec: ZRUŠENIE PRÍKAZU NA ZAČATIE EXEKÚCIE - naša značka: EX 13014/13
EXEKUČNÝ PRÍKAZ
PRÍKAZ NA ZAČATIE EXEKÚCIE
VEC: Zrušenie rozhodnutia.
Žiadosť o poskytnutie súčinnosti pri vykonávaní exekúcie
PRÍKAZ NA ÚHRADU TROV EXEKÚCIE
- Príkaz na začatie exekúcie
- Exekučný príkaz
- Uznesenie (exekúcia) – napr. od ? XY ?
- Daňový exekučný príkaz (od SocPoist, Obce, Ministerstva, Policajného zboru, DU, Sudu)
- Žiadosť o poskytnutie súčinnosti
- Oznámenie o ukončenie exekúcie
- Zmena súdneho exekútora
- Exekučný príkaz na úhradu trov
- Zrušenie príkazu na vykonávanie zrážok
- Rozhodnutie o zastavení
- Odblokovanie mzdy
- Výzva (súčinnosť)
- Súčinnosť s doručenkou
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}