import re
regex = re.compile(r"s\p{L}\p{L}innosti|s\p{L}\p{L}innos\p{L}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("EXEKUČNÝ PRÍKAZ NA VYKONANIE EXEKÚCIE ZRÁŽKAMI ZO MZDY\n"
" PRÍKAZ NA ZAČATIE EXEKÚCIE ZRÁŽKAMI ZO MZDY A INÝCH PRÍJMOV\n"
"Žiadosť o poskytnutie súčinnosti pri vykonávaní exekúcie:\n"
"Výzva zamestnávateľovi – žiadosť o poskytnutie súčinnosti\n"
"zastavenie exekúcie\n"
"ZRUŠENIE EXEKUČNÉHO PRÍKAZU\n\n"
"Vec: ZRUŠENIE EXEKUČNÉHO PRÍKAZU - naša značka: EX 11299/08 vrátane všetkých\n"
"Vec: ZRUŠENIE PRÍKAZU NA ZAČATIE EXEKÚCIE - naša značka: EX 13014/13\n"
" EXEKUČNÝ PRÍKAZ\n"
" PRÍKAZ NA ZAČATIE EXEKÚCIE\n"
"VEC: Zrušenie rozhodnutia.\n"
"Žiadosť o poskytnutie súčinnosti pri vykonávaní exekúcie\n"
" PRÍKAZ NA ÚHRADU TROV EXEKÚCIE\n\n"
"- Príkaz na začatie exekúcie \n"
"- Exekučný príkaz\n"
"- Uznesenie (exekúcia) – napr. od ? XY ?\n"
"- Daňový exekučný príkaz (od SocPoist, Obce, Ministerstva, Policajného zboru, DU, Sudu) \n"
"- Žiadosť o poskytnutie súčinnosti\n"
"- Oznámenie o ukončenie exekúcie\n"
"- Zmena súdneho exekútora\n"
"- Exekučný príkaz na úhradu trov\n"
"- Zrušenie príkazu na vykonávanie zrážok\n"
"- Rozhodnutie o zastavení\n"
"- Odblokovanie mzdy\n"
"- Výzva (súčinnosť)\n"
"- Súčinnosť s doručenkou\n\n\n\n\n\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")