using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9._]+@(?:hotmail|terra|yahoo|bol)(?:\.com\.br))";
string input = @"valdeir@hotmail.com.br";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}