re = /([a-zA-Z0-9._]+@(?:hotmail|terra|yahoo|bol)(?:\.com\.br))/
str = 'valdeir@hotmail.com.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end