$re = '/([a-zA-Z0-9._]+@(?:hotmail|terra|yahoo|bol)(?:\.com\.br))/';
$str = 'valdeir@hotmail.com.br';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);