using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?> ( \( (?> [^()]*(?1)?)* \) ) | [^,()]+ | (?P<error>[()]+) )+";
string input = @"dg(dsfsd, (d,d,g)(g,as(d,f) fdg) sdfs, sf)ad )(asg , adgda (a) adg, a, g, as)dgdg,dg sfg(f,g, (dff, d)df, g) kd";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}