import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?> ( \\( (?> [^()]*(?1)?)* \\) ) | [^,()]+ | (?P<error>[()]+) )+";
final String string = "dg(dsfsd, (d,d,g)(g,as(d,f) fdg) sdfs, sf)ad )(asg , adgda (a) adg, a, g, as)dgdg,dg sfg(f,g, (dff, d)df, g) kd";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}