$re = '/(?> ( \( (?> [^()]*(?1)?)* \) ) | [^,()]+ | (?P<error>[()]+) )+/x';
$str = 'dg(dsfsd, (d,d,g)(g,as(d,f) fdg) sdfs, sf)ad )(asg , adgda (a) adg, a, g, as)dgdg,dg sfg(f,g, (dff, d)df, g) kd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);