#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z]:\\((?:[a-zA-Z0-9() ]*\\)*).*"
Local $sString = "C:\Users\username\Documents\Files\aa.xx" & @CRLF & _
"C:\Users\username\chocolate\Files\aa.xx" & @CRLF & _
"C:\Users\username\Documents\Files\aa.xx" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")