package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]:\\((?:[a-zA-Z0-9() ]*\\)*).*`)
var str = `C:\Users\username\Documents\Files\aa.xx
C:\Users\username\chocolate\Files\aa.xx
C:\Users\username\Documents\Files\aa.xx
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}