$re = '/[a-zA-Z]:\\\\((?:[a-zA-Z0-9() ]*\\\\)*).*/m';
$str = 'C:\\Users\\username\\Documents\\Files\\aa.xx
C:\\Users\\username\\chocolate\\Files\\aa.xx
C:\\Users\\username\\Documents\\Files\\aa.xx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);