$re = '/(?:[0-9A-Za-z]+)/m';
$str = 'POST_123456789_12345678_XX123456/01-2022-123456789-654321-Lieferschein.tif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);