re = /(?:[0-9A-Za-z]+)/m
str = 'POST_123456789_12345678_XX123456/01-2022-123456789-654321-Lieferschein.tif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end