// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[0-9A-Za-z]+)").unwrap();
let string = "POST_123456789_12345678_XX123456/01-2022-123456789-654321-Lieferschein.tif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}