using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/site.ru\/[^\/]+\/$";
string input = @"https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}