$re = '/https:\/\/site.ru\/[^\/]+\/$/m';
$str = 'https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);