const regex = /https:\/\/site.ru\/[^\/]+\/$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/site.ru\\\/[^\\\/]+\\\/$', 'gm')
const str = `https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}