import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:Mr|Miss|dr|lord)? )?((?:[A-Z]\\w*(?:[ -][A-Z]\\w*)*|[a-z]+(?: [a-z]+)))\\b";
final String string = "Mr Bob Smith\n"
+ "Miss Jessica Blue\n"
+ "tim white\n"
+ "dr Lisa S pink\n"
+ "lord Lee Kensington-Smithe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}