re = /\b(?:(?:Mr|Miss|dr|lord)? )?((?:[A-Z]\w*(?:[ -][A-Z]\w*)*|[a-z]+(?: [a-z]+)))\b/m
str = 'Mr Bob Smith
Miss Jessica Blue
tim white
dr Lisa S pink
lord Lee Kensington-Smithe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end