import re
regex = re.compile(r"\b(?:(?:Mr|Miss|dr|lord)? )?((?:[A-Z]\w*(?:[ -][A-Z]\w*)*|[a-z]+(?: [a-z]+)))\b", flags=re.MULTILINE)
test_str = ("Mr Bob Smith\n"
"Miss Jessica Blue\n"
"tim white\n"
"dr Lisa S pink\n"
"lord Lee Kensington-Smithe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")