package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name\s*=\s*['\"].*?['\"]`)
var str = `<input type="hidden" name="mode" value="<?=$modeValue?>"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}