re = /name\s*=\s*['\"].*?['\"]/m
str = '<input type="hidden" name="mode" value="<?=$modeValue?>"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end