$re = '/name\s*=\s*[\'\"].*?[\'\"]/m';
$str = '<input type="hidden" name="mode" value="<?=$modeValue?>"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);