package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0*(?:[1-9]\d*(?:\.\d*)?|\.0*[1-9]\d*)`)
var str = `2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2.
BUT NOT
0, 0.0, 00.0, 0.00, 00.00, .0, 0.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}