#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d*-*(?<=^.{5})[A-Z\d-]*$"
Local $sString = "12345ABC" & @CRLF & _
"12345123" & @CRLF & _
"1234-1" & @CRLF & _
"1234--1" & @CRLF & _
"1----1AB" & @CRLF & _
"-----" & @CRLF & _
"--1--BB" & @CRLF & _
"----1-" & @CRLF & _
"1-1--11" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")