const regex = /^\d*-*(?<=^.{5})[A-Z\d-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*-*(?<=^.{5})[A-Z\\d-]*$', 'gm')
const str = `12345ABC
12345123
1234-1
1234--1
1----1AB
-----
--1--BB
----1-
1-1--11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}