import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*-*(?<=^.{5})[A-Z\\d-]*$";
final String string = "12345ABC\n"
+ "12345123\n"
+ "1234-1\n"
+ "1234--1\n"
+ "1----1AB\n"
+ "-----\n"
+ "--1--BB\n"
+ "----1-\n"
+ "1-1--11\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}