$re = '/{(?<token>\w*)(:(?<format>.*?))?}/';
$str = '{ "numericField": "{age:%d}", "strField": "{name}", "datefield": "{dateofbith:yyyy-MM-dd}" }";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);