using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<player>[\w ]+?) (tries to )?hit(s)? (?<target>[\w ]+)";
string input = @"John the Great hits the red ball
John the Great tries to hit the red ball
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}