$re = '/^(?<player>[\w ]+?) (tries to )?hit(s)? (?<target>[\w ]+)/m';
$str = 'John the Great hits the red ball
John the Great tries to hit the red ball
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);