re = /^(?<player>[\w ]+?) (tries to )?hit(s)? (?<target>[\w ]+)/m
str = 'John the Great hits the red ball
John the Great tries to hit the red ball
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end