#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[tag\](?!\s*\[\/tag\])(.*?)\[\/tag\]"
Local $sString = "[tag][/tag]" & @CRLF & _
"[tag] [/tag]" & @CRLF & _
"[tag][new]Text[/new][/tag]" & @CRLF & _
"[tag] text [/tag]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")