$re = '/\[tag\](?!\s*\[\/tag\])(.*?)\[\/tag\]/m';
$str = '[tag][/tag]
[tag] [/tag]
[tag][new]Text[/new][/tag]
[tag] text [/tag]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);