re = /\[tag\](?!\s*\[\/tag\])(.*?)\[\/tag\]/m
str = '[tag][/tag]
[tag] [/tag]
[tag][new]Text[/new][/tag]
[tag] text [/tag]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end