$re = '/^[\w-.]+@(?:[\w-]+\.)+[a-z]{2,6}$/m';
$str = '123-.@qq.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);