#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z])([a-zA-Z\d]+)$"
Local $sString = "This is success scenario:" & @CRLF & _
"123456a" & @CRLF & _
"123a456" & @CRLF & _
"1aaaaaa" & @CRLF & _
"abacefj" & @CRLF & _
"1a45s4d" & @CRLF & _
"This is wrong scenaio:" & @CRLF & _
"12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")