using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])([a-zA-Z\d]+)$";
string input = @"This is success scenario:
123456a
123a456
1aaaaaa
abacefj
1a45s4d
This is wrong scenaio:
12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}