#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?|\.\d+)$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"1.2" & @CRLF & _
"-1.2" & @CRLF & _
".123" & @CRLF & _
"-.124" & @CRLF & _
"0.12" & @CRLF & _
"-0.112" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")