$re = '/^-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?|\.\d+)$/m';
$str = '0
1
-1
1.2
-1.2
.123
-.124
0.12
-0.112
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);