const regex = /^-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?|\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?:(?=[1-9]|0(?!\\d))\\d+(?:\\.\\d+)?|\\.\\d+)$', 'gm')
const str = `0
1
-1
1.2
-1.2
.123
-.124
0.12
-0.112
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}