use strict;
my $str = ' abc 4.195.4.205.1.999 fgh 23.59.10.662 juia abc 195.4.205.1 fgh abc 4.195.4.205.1 fgh abc 4.195.4.205.1.99 fghabc 4.195.4.205.1.999 fgh';
my $regex = qr/(?:\d+\.)*((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}