// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d+\.)*((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})").unwrap();
let string = " abc 4.195.4.205.1.999 fgh 23.59.10.662 juia abc 195.4.205.1 fgh abc 4.195.4.205.1 fgh abc 4.195.4.205.1.99 fghabc 4.195.4.205.1.999 fgh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}