$re = '/(?:\d+\.)*((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})/m';
$str = ' abc 4.195.4.205.1.999 fgh 23.59.10.662 juia abc 195.4.205.1 fgh abc 4.195.4.205.1 fgh abc 4.195.4.205.1.99 fghabc 4.195.4.205.1.999 fgh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);