# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\b[MCDXLVI]{1,6}\b)M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3})/\U$0/gmi;t' <<< "Act IX: The End
Act iX: The End
Act Ix: The End
Act ix: The End
Act IX : The End
Act iX : The End
Act Ix : The End
Act ix : The End
i also me
only ii two
the iii three
what about iv
I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
XIII
XIV
XV
XVI
XVII
XVIII
XIX
XX
XLIV
XLIX
LXXIX
XCIV
XCIX
C
CI
CII
CIII
CIV
CVI
CIX
CD
CM
CC
CCC
D
DC
DCC
DCCC
CX
CXX
CXIX
CMXCIX
"